Problem
Unter
Network Mobile sind im MX560 Router die richtigen Zugangsdaten (APN, Username, Password) für die eingesetzte SIM-Karte eingestellt.
Aber speziell bei Einsatz einer Roaming SIM-Karte (z.B. mdex EASY SIM, Telenor Denmark, ...) baut der MX560 Router trotzdem keine mobile Datenverbindung zu mdex auf. Der SIM-Karte wird anstelle der IP-Adresse von mdex eine andere (temporäre) IP-Adresse direkt vom Netzanbieter zugewiesen. Der MX560 Router ist somit nicht über die mdex IP-Adresse per Remote erreichbar. Möglicherweise hat der MX560 Router auch keinen abgehenden Zugriff auf das Internet.
Eine Rücksetzung des MX560 auf Werkseinstellung, ein erneutes Einspielen der Firmware und die erneute Eingabe der korrekten Zugangsdaten (APN, Username, Password) konnten das Problem nicht beheben.
Ursache
Im Modem des MX560 Routers sind möglicherweise falsche "PDP context" Einstellungen gespeichert, so dass anstelle der im MX560 Router eingestellten Zugangsdaten (APN, Username, Password) die Verbindung direkt zum Netzanbieter hergestellt wird. Der Modemspeicher lässt sich jedoch nicht durch einen Reset des MX560 Routers oder durch erneutes Aufspielen der Firmware löschen.
Lösung
Die falschen "PDP context" Einträge im Modemspeicher des MX560 Routers können mit folgenden Schritten gelöscht werden:
Option 1: Per WebUI
- Loggen Sie sich im MX560 Router ein.
- Klicken Sie auf System User Scripts und tragen dort nachfolgenden Befehle ein (vorhandene ersetzen), dann mit Save speichern:
gsmctl -A 'AT+CGDCONT=1'
gsmctl -A 'AT+CGDCONT=2'
gsmctl -A 'AT+CGDCONT=3'
- Machen Sie ein Reboot des MX560 Routers.
(Der "PDP context" Modemspeicher wird beim Bootvorgang des MX560 Routers nun gelöscht.)
- Loggen Sie sich erneut im MX560 ein, klicken auf System User Scripts, löschen die 3 Befehle wieder und klicken auf Save:
- Machen Sie erneut ein Reboot des MX560 Routers.
Die SIM-Karte im MX560 Router baut nun die mobile Datenverbindung mit den eingestellten Zugangsdaten (APN, Username, Password) auf und erhält die richtige IP-Adresse.
Option 2: Per CLI / SSH
Prüfung der akutellen Modem-Einstellungen:
- Per CLI oder SSH in den MX560 Router einloggen
- Mit dem Befehl gsmctl -A 'AT+CGDCONT?' können die aktuellen Modem-Einstellungen ausgelesen werden:
root@MX560:~# gsmctl -A 'AT+CGDCONT?'
+CGDCONT: 1,"IP","","0.0.0.0",0,0,0,0
+CGDCONT: 2,"IPV4V6","ims","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
+CGDCONT: 3,"IP","m2m.cda.vodafone.de","0.0.0.0",0,0,0,0
root@MX560:~#
- Mit den nachfolgenden Befehlen die aktuellen Modem-Einstellungen löschen:
gsmctl -A 'AT+CGDCONT=1'
gsmctl -A 'AT+CGDCONT=2'
gsmctl -A 'AT+CGDCONT=3'
Die jeweilige Ausführung wird mit OK bestägt, nun sind alle Einstellungen gelöscht.
- Machen Sie erneut ein Reboot des MX560 Routers.
Die SIM-Karte im MX560 Router baut nun die mobile Datenverbindung mit den eingestellten Zugangsdaten (APN, Username, Password) auf und erhält die richtige IP-Adresse.